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Lavorare con i Fireworks pop-up menus in Dreamweaver  

Su una pagina Web, un menu pop-up è uno strumento di navigazione che rimane 
nascosto fino a che l’utente non sposta il puntatore del mouse sopra un’immagine della 
pagina stessa. Per vedere un esempio , apri il file sample , quindi sposta il tuo mouse 
sopra ai bottoni del menu in alto.  

Puoi usare Fireworks per creare un pop-up menu, completo del codice JavaScript 
necessario per attivare il menu pop-up con effetti rollover, semplicemente usando le 
opzioni e inserendo i nomi e i links nel box di dialogo. Una volta disegnato il pop-up menu, 
puoi esporatre le immagini e il codice come un documento HTML che puoi quindi aprire in 
Dreamweaver e continuare a disegnare la tua pagina Web.  

Questo tutorial ti condurrà attraverso I passi necessari per usare Fireworks e 
Dreamweaver insieme per creare una pagina Web che contiene un pop-up menu.  

Imparerai le seguenti cose:  

 Creare un Pop up menu 

 Esportare un menu pop-upcome HTML  

 Aprire un documento Fireworks HTML  in Dreamweaver 

 Editare un menu pop-up  di Fireworks  in Dreamweaver 

 Inserire un documento HTML di Fireworks  in Dreamweaver 

Per maggiori informazioni su come lavorare coi files pop-up menu, vedi 

 Problemi di esportazione dei menu pop-up  
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Creare un menu pop-up  

Prima di iniziare a lavorare in Fireworks per creare un’immagine, assicurati di settare lo 
spazio di lavoro di Dreamweaver. Scegli Site > Define Site per definire una cartella del sito 
locale se non hai ancora definito un sito, quindi controlla le Preferences e assicurati che il 
File Types/Editor preference sia settato su Fireworks.  

Creeremo il menu pop-up in Fireworks. Un menu pop-up è fatto di diversi componenti:  

 L’immagine a cui il menu pop-up è collegato 

 Un comportamento di Fireworks in codice JavaScript che crea le voci del menu pop-
up(items) e attiva il the menu pop-upstesso 

 Links a URLs chew aprono delle pagine web quando si clicca su un item 

Comninciamo creando l’immagine su cui l’utente sposta il mouse prima che il menu pop-
upcompaia.  

 
Creare un oggetto sliced  

Puoi aggiungere un menu pop-upa qualsiasi immagine di una pagina. Il file sample include 
tre immagini pulsante acui il menu pop-upè collegato.  

Per applicare un comportamento di Fireworks a un’immagine devi convertire l’immagine in 
un oggetto. In Fireworks, se applichi una slice a un’immagine la converti in oggetto.  

Per creare un oggetto sliced:  

1  In Fireworks, scegli File > New.  

2  Nel New Document pannello, imposta l’opzione canvas (sfondo) che vuoi e clicca su 
OK. 

3  Nel pannello Tools , seleziona lo strumento rettangolo, spostalo sulla finestra del 
Documento, e trascina per disegnare un rettangolo.  

4  Seleziona quindi lo strumento Testo e clicca sul rettangolo dove vuoi inserire il testo, 
quindi nel pannello TestoEditor, digita un nome per l’item principale and imposta la 
formattazione che vuoi per il testo. 

5  Se vuoi aggiustare la posizione del titolo, seleziona lo strumento puntatore (freccia) and 
e sposta il testo all’interno del rettangolo.  

6  Se non è già selezionato, clicca sul pulsante Hide/Show Slices in basso sul toolbox di 
Fireworks in modo da vedere gli oggetti slice quando li inserisci nel documento. 

7  Usa lo strumento Puntatore per selezionare il rettangolo e scegli Insert > Slice. 

Una slice sarà applicata  al rettangolo selezionato.  
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Note: l’immagine mostra un oggetto slice. Devi applicare un oggetto slice a ciascun 
item del menu principale se vuoi creare un menu pop-up.  

  

 
Aggiungere degli items a un menu pop-up  

Adesso, useremo il Set Menu pop-uppannello per aggiungere degli items al menu, 
definiremo la gerarchia del menu, i links, e sceglieremo l’aspetto visivo degli items del menu.  

Per aggiungere degli items al menu pop-up:  

1  Con l’ oggetto slice selezionato, scegli Insert > Pop-up Menu. 

 Il pannello Set Menu pop-up compare. 

2  Nella casella Text, scrivi il testo che vuoi far comparire nell’elenco del menu pop-up. 

3  Nella casella Link, scrivi l’URL completo per I file che vuoi che si aprano quando un 
utente clicca sull’item del menu.  

 
Nota: Puoi usare la casella Target del menu pop-up per decidre dove I documenti 
collegati saranno aperti, per esempio, scegli _blank per aprire il documento in una 
nuova finestra, o _self per sostituire il contenuto della finestra corrente.  

4  Clicca sul pulsante (+) per aggiungere un item alla lista.  
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5  Ripeti I punti da 2 a 4 per aggiungere tutti gli items necessari all’item principale 
selezionato del menu. 

6  Clicca su Next quando hai finito di aggiungere gli items alla lista. 

 La seconda schermata del pannello Set Menu pop-up compare. 

7  Usa l’opzione in questo pannello per personalizzare l’aspetto degli items del menu pop-
up: 

 Scegli HTML or Image (Clicca sul pulsante Image per creare immagini GIF per il pop-up 
menu; clicca sul pulsante HTML per creare un menu pop-up con del testo.) 

 Seleziona un font e una dimensione di font  

 Imposta il colore per lo stato up del pulsante e per lo stato over  
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8 Dopo aver impostato le opzioni, clicca  su Finish per chiudere il pannello Set Pop Up 
Menu. 

  

 
Posizionare un menu pop-up  
Vedrai adesso una linea blu e una serie di rettangoli blu che rappresentano come il menu 
pop-up apparirà.  
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scelta. 

 

4  Per vedere l’anteprima del menu pop-up, scegli File > Preview in Browser, or premi 
F12. 

5  Muovi il puntatore sopra al titolo del menu per far comparire il menu pop-up.  

 

6  Clicca sulla finestra del documento di Dreamweaver per renderla attiva. 

  

   
 
 

  

Esportare un menu pop-up in formato HTML  

Dopo aver completato il menu pop-up puoi esportarlo in formato HTML da usare poi in 
Dreamweaver. Quando esporti il  file Fireworks conterrà le immagini a pezzi, e il codice 
JavaScript che farà funzionare il menu pop-up.  

Prima di esportare il menu pop-up, salva il menu originale pop-up in formato PNG. É bene 
nominare il file HTML di esportazione con lo stesso nome del PNG per facilitare la 
memorizzazione e individuazione dei tuoi files.  

Esportare un menu:  

1  In Fireworks, scegli File > Export. 

 compare Il pannello Export. 

2  Nel pannello, fai le seguenti cose: 

 nel menu pop-up Save In, naviga nella cartella che hai scelto come cartella locale di 

 Nella casella File Name, digita un nome per il file.  



 7

 Nella casella File Name, digita un nome per il file.  

 Nel menu pop-up Save As, Seleziona HTML and Immagines. 

 Nel menu pop-up HTML, Seleziona Export HTML File. 

 Nel pop-up menu Slices, Seleziona Export Slices. 

 Seleziona Include Areas Without Slices. 

 Seleziona Put Immagines in Subfolder se vuoi salvare le immagini del menu pop-up in 
una cartella separata.  

 

3  Clicca su Save per esportare il menu pop-up file. 

 
Fireworks esporta le immagini slice, un file HTML e un file JavaScript. Questi files sono 
necessari per assemblare e attivare il menu pop-up. Assicurati di trasferire tutti I files sul 
tuo Web server quando pubblichi il sito.  
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Aprire un documento HTML  di Fireworks in Dreamweaver  

Adesso che hai creATO  un documento HTML che contiene le immagini de menu pop-up, puoi 
facilmente aprire il documento in Dreamweaver e continuare a disegnare la tua pagina Web.  

Aprire il documento in Dreamweaver:  

In Dreamweaver, scegli File > Open, quindi naviga e apri il documento HTML di Fireworks che 
vuoi vedere. 

Il document compare nella finestra di Dreamweaver.  

 

Puoi adesso continuare la pagina Web e disegnare in Dreamweaver.  
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Editare un menu pop-up di Fireworks in Dreamweaver  

Se hai impostato Fireworks come editor esterno delle immagini per le tue immagini, puoi 
apportare delle modifiche al menu pop-up  in Fireworks mentre lavori in Dreamweaver. Per 
esempio puoi aggiungere, cancellare o aggiornare gli items del menu, cambiarne font, stile dei 
pulsanti , colori, aggiornare links e così via.  

To edit a Fireworks table in Dreamweaver:  

1 Se il pannello Property inspector non è già aperto, scegli Window > Properties per 
mostrarlo. Se necessario, clicca sul triangolo in basso a destra del Property inspector per 
espandere il pannello stesso. 

2 Nel documento Dreamweaver, clicca sull’immagine a cui il menu pop-up è collegato. 

 Il Property inspector mostra che hai Selezionato un’immagine Fireworks. 

3 Clicca sul  tag <table> per Selezionare l’intera tabella di Fireworks. 

4 Nel Property inspector, clicca su Edit per lanciare Fireworks.  
 

 

  
 

 Fireworks viene aperto in modalità editing da Dreamweaver.  
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5  Nel pannello Tools di Fireworks, Seleziona lo Strumento puntatore, e clicca sull’oggetto 
slice per selezionarlo. 

 compare il menu pop-up contornato. 

6  Fai Doppio-clic sul menu pop-up contornato. 

 
compare il pannello Set Popup Menu. Puoi aggiungere, cambiare ordine, o cancellare gli 
items del menu nella prima schermata, o modificare l’aspetto e I colori del pop-up menu 
nella seconda schermata del pannello. 

7  Quando hai finito di aggiornare il menu pop-up, clicca su Done.  

 Le modofiche sono automaticamante aggiornate sul documento Dreamweaver e sul file 
sorgente originale in formato PNG.  

  

    
 
 

  

inserire un documento HTML di Fireworks in Dreamweaver  

Un altro modo di lavorarew con i menu pop-up è inserire il codice HTML  di Fireworks in un 
documento Dreamveaver esistente. I seguenti punti descrivono come usare il comando Insert 
Fireworks HTML per inserire  un menu pop-up in un documento Dreamweaver.  

Per prima cosa, apri il documento Dreamweaver per determinare dove vuoi posizionare il menu 
pop-up. Quindi aggiungi la tabella di Fireworks per inserire  il file HTML esportato.  
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Inserire un codice HTML di Fireworks:  

1  Se non l’ho hai già fatto, salva il  documento Dreamweaver dove stai per inserire il codice 
HTML  di Fireworks. 

2  In Dreamweaver, clicca sul pulsante Insert Fireworks HTML nella categoria Common del 
panello Oggetti. 

3  Nel pannello che compare, clicca su Browse, e naviga fino a trovare il file HTML  di 
Fireworks che vuoi inserire nel documento Dreamweaver quindi  clicca su Open.  

4  Clicca su OK per inserire la tabella di Fireworks. 

5  Scegli File > Save per salvare la pagina. 
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Problemi di esportazione di un menu pop-up 

Quando visualizzi l’anteprima del menu pop-up in un browser, il menu stesso può non apparire 
nella posizione voluta.  

Gli items del menu pop-up possono sbordare rispetto all’item principale. Comunemente ciò 
accade quando I margini del documento di Dreamweaver non sono impostati a 0.  

 

Impostare I margini di pagina di Dreamweaver:  

1  Scegli Modify > page Properties 

2  Nel campo Left Margin , scrivi 0. 

3  Nel campo Top Margin , scrivi 0. 

4  Clicca su OK per impostare le proprietà di pagina  

5  Premi F12, per visualizzare l’anteprima della pagina in un browser. 

  

Un altro problema comune insorge quando si inserisce un menu pop-up in una pagina in una 
posizione diversa che in alto a sinistra. L’immagine principale è mostrata dove previsto; gli items 
del pop-up menu, invece, compaiono in alto a sinistra (vedi figura seguente). Puoi risolvere 
questo problema aggiustando la posizione assoluta degli items del menu pop-up nel codice 
sorgente HTML in Fireworks.  
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Per consigli su come risolvere problemi specifici e per imparare altre cose sui menu pop-up di 
Fireworks, vai alle seguenti  Fireworks TechNotes:  

 Changing the location of a Menu pop-upexported from Fireworks 

 Customizing and troubleshooting Menu pop-upimmagines 

   
 
 


